Posted by: Mudassir Ali | August 12, 2010

Router – AutoQoS vs AutoQoS Trust

Router – AutoQoS vs AutoQoS Trust
compared the Frame Relay AutoQoS profiles, generated by the command “auto qos voip” and “auto qos voip trust”, and here are the differences: 

AutoQoS Trust AutoQoS
class-map match-any AutoQoS-VoIP-RTP-Trust
match ip dscp ef
class-map match-any AutoQoS-VoIP-Control-Trust
match ip dscp cs3
match ip dscp af31
class-map match-any AutoQoS-VoIP-Remark 

match ip dscp ef

match ip dscp cs3

match ip dscp af31

class-map match-any AutoQoS-VoIP-Control-UnTrust

match access-group name AutoQoS-VoIP-Control

class-map match-any AutoQoS-VoIP-RTP-UnTrust

match protocol rtp audio

match access-group name AutoQoS-VoIP-RTCP

policy-map AutoQoS-Policy-Trust
class AutoQoS-VoIP-RTP-Trust
priority percent 70
<!–[if !supportLineBreakNewLine]–>
<!–[endif]–> 

class AutoQoS-VoIP-Control-Trust
bandwidth percent 5
<!–[if !supportLineBreakNewLine]–>
<!–[endif]–>

class class-default
fair-queue

policy-map AutoQoS-Policy-UnTrust 

class AutoQoS-VoIP-RTP-UnTrust

priority percent 70

set dscp ef

class AutoQoS-VoIP-Control-UnTrust

bandwidth percent 5

set dscp af31

class AutoQoS-VoIP-Remark

set dscp default

class class-default

fair-queue

interface Serial0/2/0
frame-relay traffic-shaping
<!–[if !supportLineBreakNewLine]–>
<!–[endif]–>
interface Serial2/0 

frame-relay traffic-shaping

interface Serial0/2/0.1 point-to-point
bandwidth 768
frame-relay interface-dlci 301 CISCO
class AutoQoS-FR-Se0/2/0-301
auto qos voip trust
frame-relay ip rtp header-compression
<!–[if !supportLineBreakNewLine]–>
<!–[endif]–>
interface Serial2/0.12 point-to-point 

bandwidth 768
frame-relay interface-dlci 102 CISCO

class AutoQoS-FR-Se0/2/0-102

auto qos voip

frame-relay ip rtp header-compression

ip access-list extended AutoQoS-VoIP-Control 

permit tcp any any eq 1720

permit tcp any any range 11000 11999

permit udp any any eq 2427

permit tcp any any eq 2428

permit tcp any any range 2000 2002

permit udp any any eq 1719

permit udp any any eq 5060

ip access-list extended AutoQoS-VoIP-RTCP

permit udp any any range 16384 32767

map-class frame-relay AutoQoS-FR-Se0/2/0-301
service-policy output AutoQoS-Policy-Trust 

frame-relay fragment 960

frame-relay cir 768000
frame-relay bc 7680
frame-relay be 0
frame-relay mincir 768000

map-class frame-relay AutoQoS-FR-Se0/2/0-102 

service-policy output AutoQoS-Policy-UnTrust

frame-relay fragment 960

frame-relay cir 768000
frame-relay bc 7680
frame-relay be 0
frame-relay mincir 768000

Here is comparison of the results of “auto qos voip fr-atm” and “auto qos voip trust fr-atm” commands. (differences are in the red)

AutoQoS Trust Fr-Atm AutoQos Fr-Atm
class-map match-any AutoQoS-VoIP-RTP-Trust
match ip dscp ef
class-map match-any AutoQoS-VoIP-Control-Trust
match ip dscp cs3
match ip dscp af31
class-map match-any AutoQoS-VoIP-Remark 

match ip dscp ef

match ip dscp cs3

match ip dscp af31

class-map match-any AutoQoS-VoIP-Control-UnTrust

match access-group name AutoQoS-VoIP-Control

class-map match-any AutoQoS-VoIP-RTP-UnTrust

match protocol rtp audio

match access-group name AutoQoS-VoIP-RTCP

policy-map AutoQoS-Policy-Trust
class AutoQoS-VoIP-RTP-Trust
priority percent 70
<!–[if !supportLineBreakNewLine]–>
<!–[endif]–> 

class AutoQoS-VoIP-Control-Trust
bandwidth percent 5
<!–[if !supportLineBreakNewLine]–>
<!–[endif]–>

class class-default
fair-queue
<!–[if !supportLineBreakNewLine]–>
<!–[endif]–>

policy-map AutoQoS-Policy-UnTrust 

class AutoQoS-VoIP-RTP-UnTrust

priority percent 70

set dscp ef

class AutoQoS-VoIP-Control-UnTrust

bandwidth percent 5

set dscp af31

class AutoQoS-VoIP-Remark

set dscp default

class class-default

fair-queue

interface Serial0/0
frame-relay traffic-shaping
<!–[if !supportLineBreakNewLine]–>
<!–[endif]–>
interface Serial0/0
frame-relay traffic-shaping
<!–[if !supportLineBreakNewLine]–>
<!–[endif]–>
interface Serial0/0.1 point-to-point
bandwidth 512
frame-relay interface-dlci 201 ppp Virtual-Template200
class AutoQoS-FR-Se0/0-201
auto qos voip trust fr-atm
<!–[if !supportLineBreakNewLine]–>
<!–[endif]–>
interface Serial0/2/0.1 point-to-point 

bandwidth 768

frame-relay interface-dlci 102 ppp Virtual-Template200

class AutoQoS-FR-Se0/2/0-102

auto qos voip fr-atm

interface Virtual-Template200
bandwidth 512
ppp multilink
ppp multilink interleave
ppp multilink fragment delay 10
service-policy output AutoQoS-Policy-Trust
<!–[if !supportLineBreakNewLine]–>
<!–[endif]–>
interface Virtual-Template200 

bandwidth 768

ppp multilink

ppp multilink interleave

ppp multilink fragment delay 10

service-policy output AutoQoS-Policy-UnTrust

map-class frame-relay AutoQoS-FR-Se0/0-201
frame-relay cir 512000
frame-relay bc 5120
frame-relay be 0
frame-relay mincir 512000
map-class frame-relay AutoQoS-FR-Se0/0-201
frame-relay cir 512000
frame-relay bc 5120
frame-relay be 0
frame-relay mincir 512000
ip access-list extended AutoQoS-VoIP-Control 

permit tcp any any eq 1720

permit tcp any any range 11000 11999

permit udp any any eq 2427

permit tcp any any eq 2428

permit tcp any any range 2000 2002

permit udp any any eq 1719

permit udp any any eq 5060

ip access-list extended AutoQoS-VoIP-RTCP

permit udp any any range 16384 32767

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Categories

%d bloggers like this: